Votre navigateur n'accepte pas les coockies
Accueil

légende :

  Indispensable
  Intéressant
  Très utile

Propriétés icone propriété VBA

1- Principales propriétés des objets

Les objets Excel sont définis par un ensemble de propriétés (qu’on appelle aussi attributs).

On y fait référence par : Objet.Propriété

On trouve les propriétés dans la fenêtre des propriétés de l’éditeur VB :

fenêtre des propriétés VBA

Ou dans le code directement lors de la saisie.

saisie des propriétés à la volée

Les propriétés peuvent être consultées ou modifiées (affection Objet.Propriété=valeur) ;

2- Exemples

Les propriétés les plus usitées dans les procédures sont :

2.a.  CurrentRegion

2.b.  End

2.c.  FormulaLocal

VBA utilise les noms des fonctions en anglais avcec la propriété Formula. La propriété FormulaLocal permet d’utiliser le nom français

Range("A1").Formula = "=SUM(A2:A8)"
Range("A1").FormulaLocal = "=SOMME(A2:A8)"

2.d.  Name

Pour activer une feuille de calcul vous pouvez procéder de deux manières :

2.e.  Offset

2.f.  Path

Quand l’utilisateur ouvre un classeur depuis l’Explorateur de Windows, la commande d’ouverture de classeurs de Excel pointe vers le répertoire par défaut.

Si le classeur en cours nécessite l’ouverture d’un second classeur situé dans le même répertoire, Excel ne le trouvera pas.

La solution consiste à créer systématiquement une variable pour identifier le répertoire du classeur ouvert.

varChemin = Workbooks("Exercice1.xlsm").Path

Ensuite on utilise cette variable dans la procédure douverture du second classeur.

Workbooks.Open varChemin & "\Exercice2.xlsx"

2.g.  Value (valeur d‘une cellule)

Pour insérer un texte dans une cellule, il faut mettre ce texte entre guillemets

Range("A1").Value = "Mon texte"

2.h.  Hidden

2.i.  Locked

2.j.  NumberFormat

2.k.  Visible (à utiliser avec True et False pour afficher ou masquer)

2.l.  Save

2.m.  Count (nombre de cellules d‘une page, de feuilles de classeur…)